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Introduction

The NetApp Element .NET SDK is a collection of libraries that facilitate integration and
orchestration between proprietary systems and third-party applications. The .NET SDK allows
developers to deeply integrate Element storage-based system API with the C# or Visual Basic
programming languages. The NetApp Element .NET SDK reduces the amount of additional
coding time required for integration.

The intended audience for this document is C# or Visual Basic developers who are responsible for
integrating Element storage functionality into other applications.

Note: All version 12.3 SDK languages have identical Element storage functionality and
available APIs.
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Compatibility and dependencies

The Element .NET SDK is compatible with and depends on specific releases of software.

Compatibility
Component Version
.NET Core 2.2
Element software 11.0-12.3

Dependencies

Component \ersion

Newtonsoft.Json 11.0.2
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Installing the NetApp Element .NET SDK

Complete the following steps to bring the NetApp Element .NET SDK into your environment.
Steps
1. Download the sol i df i r e- sdk- dot net . t ar. gz from the NetApp Support Site.

2. Unzip the downloaded file into your directory.
3. Right Click (3£ Click) on your C# Project and select Add > Reference....

[ Solution O %  * Program.cs o
¥ [& HelloSolidFire Mo selection
.......................................................... Build HelloSolidFire asigay s INg. System;
» B3 De j i & E ~
i Rebuild HEHGS?“E!F”'E #K namespace HelloSolidFire
[C]] Program.cs Clean HelloSolidFire GEK {
Unload class Program
{
Run Project static void Main(str.
. . {
S D:ebuggmg Rroject Console.WritelLim
Run With > }
Set As Startup Project by
}
Pack
Publish (3
B Nev File...
New Class...
Manage NuGet Packages... Existing Files... " 38A

el )

Version Control

MNuGet Packages...
Analyze Source

Find in Files... T+ ¥F Files from Folder...

Reveal in Finder Existing Folder...
Mew Folder...

Copy #C

Cut X Add Docker Support

Remove 3 <l

Rename... #R

Edit Project File
Options

Refresh

4.  From the References window, open the .Net Assembly tab and select browse.


HTTPS://MYSUPPORT.NETAPP.COM/SITE/PRODUCTS/ALL/DETAILS/ELEMENTSDK/DOWNLOADS-TAB
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[& Solution O

¥ [& HelloSolidFire
¥ 7] HelloSolidFire
* B Dependencies
* B As=emblies

L) SolidFire.SDK
* B} Frameworks

[¥] Microsoft.NETGore.App (3.1.0)
[} Program.cs

5. Select the SolidFire.SDK.dII from the unzipped package and click OK.

Confirm that the SolidFire.SDK.dII has been successfully added to the Project >
Dependencies > Assemblies folder.

[®] Solution O

v [& HelloSolidFire
* [7] HelloSolidFire
¥ B Dependencies
» B Assemblies

L) SolidFire.SDK
* B3 Frameworks

(Y] Microsoft.NETCore.App (3.1.0)
@ Program.cs

7. Install the Newtonsoft.Json dependency package from NMuGet.
From the Project menu, select Manage NuGet Packages....

In the Manage NuGet Packages window, select the nuget.org package source, search and
select the Newtonsoft.Json package, and click Add Package.

| NN Manage NuGet Packages - Soll

nuget.org |_J Browse Installed Updates Consolidate

Newtonsoft.Json 53,06,07 605
Json.NET is a popular high-performance JSON framework for .NET

Microsoft.Extensions.Logging 24,19,94,036

Logging infrastructure default implementation for
Microsoft.Extensions.Logging.

Microsoft.Extensions. Dependencylnjection 22,60,82,431

Default implementation of dependency injection for
Microsoft.Extensions.Dependencylnjection.

10. Confirm that the package has been added to the Project > Dependencies > NuGet folder.


https://www.nuget.org/
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[ Solution o =

¥ [& HelloSolidFire
» [] HelloSolidFire
+ B Dependencies
* [ Aszemblies
& SolidFire. 50K
+* B Frameworks
[¥] Microsoft. NETCore.App (3.1.0)
* [ NuGet

'O Newtonsoft.lson (12.0.3)

[t} Program.cs
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What's new in this release

The Element SDK version 12.3 release expands supported NetApp Element software APl methods
through version 12.3. This release also contains revised parameters for existing methods.

NetApp Element SDK API methods

NetApp Element SDK version 12.3 provides Element storage APl methods. The availability of
each API depends on the version of Element software.

o New API methods for Element software 12 on page 8
o New API methods for Element software 11 on page 9

For more detail on Element storage APl methods, refer to the Element AP/ Reference Guide for
your operating system.

New APl methods for Element software 12
NetApp Element SDK version 12.3 includes Element 12 methods.

The following version 12.3 APl methods have been added to all SDK languages:
Node

¢ GetPatchlnfo
¢ ListNetworklInterfaceStats

Encryption

e GetEncryptionAtRestinfo
« GetSoftwareEncryptionAtRestInfo
» RekeySoftwareEncryptionAtRestMasterKey

The following version 12.2 APl methods have been added to all SDK languages:
Cluster

« DisableMaintenanceMode
« EnableMaintenanceMode
» GetLicenseKey

o SetLicenseKey

The following version 12.0 APl methods have been added to all SDK languages:
Cluster

» DeleteAuthSession

e DeleteAuthSessionsByClusterAdmin
» DeleteAuthSessionsByUsername

* GetBinAssignmentProperties

e GetProtectionDomainLayout

» ListActiveAuthSessions

» ListAuthSessionsByClusterAdmin

e ListAuthSessionsByUsername

e SetProtectionDomainLayout

IDP

e AddldpClusterAdmin
e CreateldpConfiguration
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DeleteldpConfiguration
DisableldpAuthentication
EnableldpAuthentication
GetldpAuthentication
ListldpConfigurations
UpdateldpConfiguration

New APl methods for Element software 11
NetApp Element SDK version 12.3 includes Element 11 methods.

The following version 11.8 APl methods have been added to all SDK languages:

Cluster

Node

CreateClusterInterfacePreference
CheckProposedNodeAdditions
DeleteClusterInterfacePreference
GetActiveTIsCiphers
GetClusterInterfacePreference
GetClusterStructure
GetSupportedTIsCiphers
ListClusterInterfacePreferences
ListProtectionDomainLevels
ModifyClusterInterfacePreference
ResetSupplemental TIsCiphers
SetClusterStructure (Not supported in Python SDK and the CLI)
SetSupplemental TIsCiphers
TestAddressAvailability

CheckProposedCluster
ControlPower
DisableAutolp
EnableAutolp
GetLIdpConfig
GetNodeFipsDrivesReport
SetLIdpConfig

AddKeyServerToProviderKmip
CreateKeyProviderKmip
CreateKeyServerKmip
CreatePublicPrivateKeyPair
DeleteKeyProviderKmip
DeleteKeyServerKmip
GetClientCertificateSignRequest
GetFipsReport
GetKeyProviderKmip
GetKeyServerKmip
ListKeyProvidersKmip
ListKeyServersKkmip
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ModifyKeyServerKmip
RemoveKeyServerFromProviderKmip
TestKeyProviderKmip
TestKeyServerKmip

SnapMirror

AbortSnapMirrorRelationship
BreakSnapMirrorRelationship
CreateSnapMirrorEndpointUnmanaged
CreateSnapMirrorRelationship
CreateSnapMirrorVolume
DeleteSnapMirrorRelationships
GetOntapVersionInfo
GetSnapMirrorClusterldentity
InitializeSnapMirrorRelationship
ListSnapMirrorAggregates
ListSnapMirrorLuns
ListSnapMirrorNetworklInterfaces
ListSnapMirrorNodes
ListSnapMirrorPolicies
ListSnapMirrorRelationships
ListSnapMirrorSchedules
ListSnapMirrorVolumes
ListSnapMirrorVservers
ModifySnapMirrorEndpointUnmanaged
ModifySnapMirrorRelationship
QuiesceSnapMirrorRelationship
ResumeSnapMirrorRelationship
ResyncSnapMirrorRelationship
UpdateSnapMirrorRelationship

SSH sessions

DisableClusterSSH
EnableClusterSSH
GetClusterSSHInfo

10
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The following APIs are not supported in the Element .NET SDK version 12.3 release.

APl Name

Description

TestDrives

The SDK is unable to parse the response received from the cluster.

CheckPingOnVlan

The SDK is unable to parse the response received from the cluster.
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Where to find product documentation and other information

You can learn more about using and managing NetApp HCI and SolidFire all-flash storage from
the resources available in the Documentation Centers and Resources pages for both products.

In the Documentation Centers, you can also find information about hardware installation and
maintenance, additional content resources available, links to known issues and resolved issues, and
the latest release notes. On the Resources pages, you can find links to data sheets, technical
reports, white papers, and videos.

»  NetApp HCI Documentation

»  NetApp HCI Documentation Center

»  NetApp HCI Resources page

» SolidFire and Element 12.3 Documentation Center
o SolidFire and Element 12.2 Documentation Center
e SolidFire and Element 12.0 Documentation Center
> SolidFire and Element 11.8 Documentation Center
» SolidFire and Element 11.7 Documentation Center
o SolidFire and Element 11.5 Documentation Center
» SolidFire Resources page


https://docs.netapp.com/us-en/hci/
http://docs.netapp.com/hci/index.jsp
https://www.netapp.com/us/documentation/hci.aspx
http://docs.netapp.com/sfe-123/index.jsp
http://docs.netapp.com/sfe-122/index.jsp
http://docs.netapp.com/sfe-120/index.jsp
http://docs.netapp.com/sfe-118/index.jsp
http://docs.netapp.com/sfe-117/index.jsp
http://docs.netapp.com/sfe-115/index.jsp
https://www.netapp.com/us/documentation/solidfire.aspx
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Contact NetApp Support
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If you need help with or have questions or comments about NetApp products, contact NetApp
Support.

e Web:

mysupport.netapp.com
* Phone:

o 888.4.NETAPP (888.463.8277) (US and Canada)
o 00.800.44.638277 (EMEA/Europe)
> +800.800.80.800 (Asia/Pacific)


http://mysupport.netapp.com
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Copyright, trademark, and machine translation
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Copyright
Copyright © 2021 NetApp, Inc. All rights reserved. Printed in the U.S.

No part of this document covered by copyright may be reproduced in any form or by any means—
graphic, electronic, or mechanical, including photocopying, recording, taping, or storage in an
electronic retrieval system—uwithout prior written permission of the copyright owner.

Software derived from copyrighted NetApp material is subject to the following license and
disclaimer:

THIS SOFTWARE IS PROVIDED BY NETAPP "AS IS" AND WITHOUT ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE,
WHICH ARE HEREBY DISCLAIMED. IN NO EVENT SHALL NETAPP BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

NetApp reserves the right to change any products described herein at any time, and without notice.

NetApp assumes no responsibility or liability arising from the use of products described herein,
except as expressly agreed to in writing by NetApp. The use or purchase of this product does not
convey a license under any patent rights, trademark rights, or any other intellectual property rights
of NetApp.

The product described in this manual may be protected by one or more U.S. patents, foreign
patents, or pending applications.

Data contained herein pertains to a commercial item (as defined in FAR 2.101) and is proprietary
to NetApp, Inc. The U.S. Government has a non-exclusive, non-transferrable, non-sublicensable,
worldwide, limited irrevocable license to use the Data only in connection with and in support of
the U.S. Government contract under which the Data was delivered. Except as provided herein, the
Data may not be used, disclosed, reproduced, modified, performed, or displayed without the prior
written approval of NetApp, Inc. United States Government license rights for the Department of
Defense are limited to those rights identified in DFARS clause 252.227-7015(b).

Trademark

NETAPP, the NETAPP logo, and the marks listed on the NetApp Trademarks page are trademarks
of NetApp, Inc. Other company and product names may be trademarks of their respective owners.

https.//www.netapp.com/company/legal/trademarks/

Machine translation
See important information about localized content at netapp.com.

https.//www.netapp.com/company/legal/machine-translation/


https://www.netapp.com/company/legal/trademarks/
https://www.netapp.com/company/legal/machine-translation/
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